Copia de seguridad


([N4] gontorre) #1

Buenos días

Os cuento una cosa que me pasa con las copias de seguridad del vServe por si le pasa a más gente:

Tengo configurada una tarea de copia diaria a las 23:00 y veo que se realiza todos los días. En vAdmin veo la hora de inicio y final y la duración. Si detengo el servicio vatp para hacer una actualización de una solución y lo vuelvo a arrancar, me marca la última copia como no realizada (cuando antes de parar el servicio aparecía como realizada) y la vuelve a hacer. Sólo ocurre cuando el reinicio de la solución implica modificaciones en alguna tabla.

Este comportamiento lo he observado en dos servidores diferentes.

¿Le pasa a alguien más?

Un saludo

Gonzalo Torre


([N3] pacosatu) #2

Hola Gonzalo.

Sí, también me ocurre.

La última tarea de copia de seguridad se ejecuta a las 3:40.
A las 2:00h. del día siguiente se hace una copia de seguridad completa de todo el servidor mediante una herramienta externa. Se reinicia el servidor por lo tanto a las 2:00h.
Veo en el registro que a las 2:00:40 se ejecuta la última tarea de de copia de seguridad del día anterior (la de las 3:40) marcándola como No realizada.

No ocurre todos los días, solo de vez en cuando (5 veces este mes).

Consúltalo a Soporte, quizás ya lo tengan detectado.

Saludos
Paco Satué


([N3] pacosatu) #3

Hola Gonzalo.

¿Alguna contestación de Soporte sobre este tema?

Saludos
Paco Satué


([N4] gontorre) #4

Buenos días

Sigo con este problema y en soporte no consiguen reproducirlo. En mi primer mensaje decía que el me marcaba la copia como No realizada cuando el reinicio implicaba cambios en la estructura de las tablas, pero en realidad no es así. Siempre que reinicio el servicio vatp me marca la última copia como No realizada y me la vuelve a hacer.

Me pasa en dos servidores diferentes uno con Windows 2008 Server y otro con Windows 2012 Server.

Por lo visto cuando arranca el vServer detecta (erroneamente) que no se ha realizado la última copia y la vuelve a lanzar. En cualquier caso, me parece un poco absurdo que el vServer haga eso. Si el reinicio del servicio se produce debido a un error corremos el riesgo de que se pierda la última copia de seguridad ya que se sobreescribiría con la que lanza en el arranque.

Un saludo

Gonzalo Torre


([N3] pacosatu) #5

Hola Gonzalo.

También me sigue ocurriendo.
Se produce de forma aleatoria, ya llevo 6 días sin que se produzca.

Yo tengo 6 tareas de copia de seguridad con una diferencia de 10 minutos. Siempre es la última Tarea la que produce el fallo.

Habrá que esperar a que a alguien más le ocurra lo mismo.

Saludos
Paco Satué