Convivir con la 7.17 y la 7.18


([N4] gontorre) #1

Buenas tardes,

Aún no he actualizado mi sistema a la versión 7.18 y me surge una duda. ¿Hay algún problema en tener un vClient versión 7.18 conectando a un vServer versión 7.17?

Gracias y un saludo


([N1] aztecmexico) #2

Buen día,

Con la 7.17 no sé, pero definitivamente no se te ocurra instalar la 7.18 conviviendo con la 7.16, me explico:

Hasta antes de la 7.18 tenia instaladas todas las versiones incluidos vservers en distintos directorios, tan simple como dependiendo de la versión con la que quisiera trabajar (tengo un cliente que sigue en producción con la 7.16) pues paraba un servicio y arrancaba otro, sin mayores problemas.

Con la 7.18 sucede que paras el servicio de la 7.16, arrancas el de la 7.18, trabajas con los componentes de la 7.18, hasta ahí todo bien.

Si terminando tus actividades con la 7.18, detienes el servicio y arrancas de nuevo el 7.16…pues más te vale que tengas respaldos de todas tus soluciones, archivos de configuración de vServer, etc, porque te vuela todo, se pierden todos los usuarios y queda el de velneo que es por defecto.

Se truenan todas tus instancias de app y de datos.

Se pierden los enlaces a las carpetas compartidas y directorios de datos.

Desde el vAdmín de la 7.16 no ves absolutamente ninguna solución, solo que arranques de nuevo el servicio de la 7.18 las visualizas, pero el daño está hecho, tienes que volver a reinstalar todas las soluciones y generar sus instancias, amén de dar de alta de nuevo a tus usuarios y borrar las carpetas compartidas y volver a crearlas.

No se pierden datos en si, bueno, se llegan a dañar algunos archivos .var pero los borras y listo, todo arranca de nuevo bien.

Conclusión, si vas a dar el brinco a la 7.18 desde la 7.16 pues debe ser definitivo, nada de andar conviviendo entre versiones, te reitero, con la 17 no lo probé.

No es crítica, imagino que por los cambios internos y estructurales de la 7.18 pues asi pasa, simplemente saberlo y estar protegidos con respaldos de todo, y, dar el brinco sin querer regresar después a versiones anteriores, a menos que tengas dos licencias de edición en local pues te quedas en una con la 7.18 y en las demás con la 7.17 y anteriores, que esas no me dieron ningún problema de lo que platico aquí.

Saludos.


([N4] gontorre) #3

Buenos días

La idea no es tener varias versiones en la misma máquina. Lo que me gustaría saber es si puedo con un vClient 7.18 puedo conectar a un vServer versión 7.17.

Imagino que será así, pero era por asegurarme.

Un saludo


([N3] pacosatu) #4

Hola Gonzalo.

De la 7.17 a la 7.18 no ha habido cambios en las librerías de QT ni en la estructura de la base de datos, así que no debe haber problemas. Yo de hecho he estado un tiempo accediendo a las aplicaciones del Cloud que estaba en la 7.17 con un cliente de la 7.18 y aparte del aviso inicial del vUpdater, no he notado nada extraño.

Aunque este tema por supuesto lo debe confirmar Soporte.

Saludos
Paco Satué


([N4] gontorre) #5

Al final me he tirado a la piscina y actualizado mi equipo, de momento sin problemas. Lo único que no se puede hacer (lógico) es acceder con vAdmin 7.18 a un vServer 7.17.

Un saludo