Configuración del sistema:Leer cadena de texto


([N3] GSI) #1

Hola a todos, es mi primer mensaje en este foro, vengo de v6, estoy empezando a desarrolar en v7 y me encuentro un problema, la función Configuración del Sistema: Leer cadena de texto, no consigo que me funcione, en v6 no tengo problema pero aqui no lo consigo, estoy intentando leer en nº de serie de windows en este caso:

"HKEY_LOCAL_MACHINE"
"SOFTWAREMicrosoftInternet ExplorerRegistration"
"ProductId"

Si alguno lo habes probado agradeceria un ejemplo, no encuentro ninguno en el manual y por mas pruebas que he hecho lo lo consigo.


([N4] velavisual) #2

@GSI

Incidencia al respecto en vBugman, número 1942.
.
.
saludos
Antonio Vela
http://www.velavisual.com


([N3] GSI) #3

Por mas que he buscado en vBugman la incidencia numero 1942 no la veo, alguien sabe si en la versión 7.7 esta resuelta, no se si el problema es que el windows es de 64bit, pero entiendo que debe leer el registro sea de 32 o de 64 no????

En caso de que a alguien le funcione, seriais tan amables de poner un ejemplo, captura de pantalla


([N4] eic) #4

Hola.

No sé si cambió de número, pero creo que la incidencia a la que se refiere Antonio es la 2534 de vBugman.

En resumen: ese comando (y el de escribir) sólo funcionan en el ámbito del usuario (HKEY_CURRENTUSERSoftware). Y no está solucionada.

Saludos,

Fran Varona


([N4] velavisual) #5

@ALL
.
Hola.
.
Imágenes de esta mañana en vBugman (21-05-2011)
.
Es posible que internamente lo tomen como VBxxxx duplicadas.
.
saludos
Antonio Vela
http://www.velavisual.com

[attachment=17781,1464]