Conexion por proxy


(Edgar) #1

Hola, soy nuevo en velneo, he descargado los componentes y estoy tratando de conectarme a mi servidor pero como salgo a internet por medio de un proxy recibo error de conexion. Busque en el foro y encontre consultas sobre este mismo tema pero no hay solucion alguna. Hay manera de solucionarlo o al tener proxy no puedo utilizar Velneo ?

Edgar.

PD.

Por la cantidad de usuarios que utilizan la conexion a internet no es posible desactivar el proxy.


([N4] fgutierrez.velneo) #2

Por el momento no es posible acceder a través de un proxy, tendrás que buscar un acceso que no le sea necesario pasar por él.

Cuando esté disponible os informaremos adecuadamente.

 

Un saludo.


(Edgar) #3

Gracias por la respuesta. Vere como puedo hacer una conexion alternativa para no pasar por el proxy....

 

Saludos





(felix) #4

Al parecer con la nueva version tampoco se puede acceder por un proxy

Saludos,


([N4] Paco Satué) #5

Hola.

Pues no me puedo creer que desde el año 2009 no hayáis dado solución a este problema.
¿No existe ninguna aplicación Velneo (6.x o V7) instalada en una empresa cuya política de seguridad obliga a que las salidas a Internet sean a través de Proxy y con autenticación de Usuario?

El objeto Visor HTML de Velneo V7 no es operativo en redes con Proxy.
La tecla F1 de vDevelop (¡¡La ayuda Online y única que existe!!) no funciona en redes con Proxy.

Insisto, ¿Ningún programador de vDevelop o Usuario de vClient o Usuario de vServer en Cloud trabaja en una red con Proxy?
Si existen, cómo ha solucionado el tema sin puentear la autenticación Proxy.

Un saludo


([N4] mittosoftware) #6

Yo tengo el mismo problema con una organización cliente.

También me parece raro que el problema exista desde hace tanto, y aún no se solucione, porque esto debería considerarse bug, no un requerimiento de característica.


([N2] gegeo) #7

Os traslado una respuesta que me dió soporte en su dia:

Velneo vWebClient/vClient V7 no puede salir a Internet directamente a través de un Proxy dado que no es posible configurar un Proxy con su puerto en ellos. Es necesario dar acceso directo a Internet a esas máquinas desde la que quieres conectarte a un servidor remoto.

([N4] Paco Satué) #8

Hola.

La contestación de Soporte, en fin, sin comentarios …

Está puesto como Idea y tiene 2 votos.
Así que evidentemente no es un problema para la comunidad de Velneo y mucho menos para los Arquitectos de Velneo.

Me gustaría un documento técnico por parte de Soporte (y experto en Comunicaciones) justificando este comportamiento.
Podéis abrir boca con el siguiente artículo http://www.csospain.es/Articulo.aspx?ida=207680&seccion=

Saludos


([N1] wikan) #9

Buenas, no pienso que sea un bug, es simplemente una funcionalidad que no tiene la herramienta.

Creo que para solventar este problema simplemente añadiendo una excepción al proxy queda solucionado. Al igual que se prohibe el acceso a determinadas urls, poner la url del vServer como segura.


([N4] Paco Satué) #10

Hola Manuel.
No es suficiente con añadir una excepción.
La aplicación Cliente debe conocer la dirección y puerto del Servidor Proxy (por ejemplo proxy.miempresa.local:3128).
Sin estos datos la Aplicación Cliente siempre intentará acceder directamente a Internet, por defecto por el puerto 80.

Creo que esto es lo que le ocurre a vDevelop con la tecla F1 y el objeto visor HTML, que por mucho que pongas reglas en el Servidor Proxy, las peticiones HTTP nunca llegan al Servidor Proxy proxy.miempresa.local:3128. Simplemente no tiene forma de saber cómo se accede al proxy, tal como hacemos en los exploradores Web o en el WIFI del smartphone de la empresa.

Pongo otros casos:

  • Los comerciales de tu empresa van a realizar demos ocasionales de tu Aplicación Velneo en la red de varias empresas interesadas. Si la Aplicación usa el visor HTML, no vas a pretender que configuren una regla proxy para la demo.
  • Un departamento de desarrollo de una gran organización quiere probar la herramienta Velneo con el Nivel 1 y no pueden tener salida directa a Internet por políticas de Seguridad.

Otro tema es el acceso al servidor vServer remoto a través del protocolo VATP y el puerto 690. Estos siempre deberán estar habilitados en la red de la empresa.

Si en definitiva es aplicar a VELNEO la misma funcionalidad que ya existe en los exploradores Web actuales.

Saludos


([N2] walter.chacon) #11

Todavia existe este problema ya que en la empresa si tenemos proxy y he tratado de aconfigurar el puerto, poner la url y nada. alguien tiene alguna solucion a este problema.

saludos


([N1] foobar) #12

quizás esto te pueda ayudar

https://www.stunnel.org/index.html

en definitiva lo que hace es que lo instalas en tu PC, tu apuntas tu cliente a tu pc, stunnel recibe la petición en tu pc y la redirecciona a la dirección que tu configures en el archivo de configuración de stunnel.

yo lo he utilizado para correo electrónico y funciona. Para lo que es una aplicación cliente / servidor no se si funcionara, la ultima vez que lo utilice fue hace 4-5 años.

si stunnel no funciona, lo que se puede hacer es crear una aplicación como stunnel , que haga de mensajero entre el cliente y el servidor

PD: no conozco velneo le estoy echando un ojo , no se como funciona, espero no estar soltando tonterias


([N1] cotines) #13

Muy buenas,
Supongo que este tema sigue igual, no?
Hay novedades? He buscado por el foro pero no he encontrado nada nuevo.
saludos


([N3] pacosatu) #14

Hola cotines.

Por alguna oscura razón, Velneo no ha documentado todavía la forma de configurar el acceso al servidor remoto a través de Proxy. Quizás es que nadie necesita esta funcionalidad, de hecho la Idea tuvo 4 votos.
De todas formas, están haciendo pruebas en Soporte y probablemente en la versión 7.15 se anuncie como novedad.

De momento, en la versión 7.14 puedes configurar el Proxy mediante claves de registro (en Windows). Con esto la ayuda F1 y el control HTML funcionan correctamente.

Por ejemplo para vDevelop sería:


[HKEY_CURRENT_USER\Software\Velneo\vDevelop\proxy]
“enabled”=dword:00000001
“type”=dword:00000001
“port”=dword:00000050
“userName”=“dominio\usuario”
“password”=“password”
“hostName”=“proxy.miemnpresa.dom”

Con la clave “enabled” activas o desactivas la configuración proxy.
Las claves “userName” y “password” funcionan solo para proxys con securización.
La clave “port” está en Hexadecimal (en este caso 50 que corresponde a 80 en decimal).

Copia estas líneas en un fichero de extensión “reg” y lo ejecutas.

Lo mismo se puede hacer para vAdmin y vClient. Tienes que cambiar la rama vDevelop por el nombre correspondiente.

Saludos
Paco Satué


([N4] eic) #15

Muy interesante noticia, Paco.

No me volvió a hacer falta, pero recuerdo que en mi época de profesor en la Escuela no podía usar Velneo desde allí, por culpa del proxy. Es una buena noticia que ya se pueda, aunque esté en pruebas.


([N1] ariel ivan ruiz mateos) #16

Hola a todos, pueden utilizar un programa que se llama proxycap, este emula la funcionalidad proxy en cualquier aplicacion que no tenga la funcionalidad implementada…

Yo lo he usado y funciona muy bien.

Espero que les sirva.

saludos.