como va la 7.18


([N3] blanyi) #1

Buenos días.

Por este foro no he visto comentarios acerca de la última versión de Velneo, la 7.18.
¿Qué pueden decirnos los que ya le hayan probado?
¿Si es estable?
¿Presenta algun error?

En fin quiero saber como les ha ido para hacerme una idea de si es fiable para actualizarnos a este última versión.

Feliz día.

YIMY MORA ACONCHA


([N1] vlinares) #2

Buenas tardes…

Yo estoy como tú.
Creo que lo montaré en una maquina virtual y veré como funciona.

Saludos

Vicente


([N4] nicodigi) #3

Pues, hasta ahora todo bien. No tengo quejas.

Consejo: si tienes vServer Cloud y vServer propio como yo, asegúrate de tener todo en la misma versión. vDeveloper 7.18 no se conectara si algún vServer es 7.17.
También me paso, y es una nota mental. Hacer backup de vServer propio antes de Actualizar.


([N3] pacosatu) #4

Hola.

De momento no ha habido quejas importantes, por lo menos en el foro.

La 7.18 no trae cambios de librerías QT ni del motor de base de datos, por lo tanto, las aplicaciones seguirán funcionando igual de bien o de mal que la 7.17, según sea el caso.

Saludos
Paco Satué


([N2] ramiro) #5

Buenas:

El principal problema que he encontrado se refiere a la impresión de Objetos Dibujo (estáticos o campos de Tabla) en los informes nativos. Pasaron a imprimirse en un tamaño ridículo (tal vez al 10% de su tamaño original o quizás menos). He tenido que cambiar el “Aspecto del dibujo” a “Estirar/EÇncoger” para corregirlo (no recuerdo como estaba antes, pero funcionaba bien).

Un problema similar se produce con la impresión (nativa) de campos de Texto enriquecido. Algunas fuentes se imprimen con tamaño cuasi-invisible. No he tenido tiempo de ir más a fondo en este problema.

vDevelop es menos estable que antes (a veces se cae, de repente, pero no veo un patrón y simplemente estoy volviendo a acostumbrarme a grabar más a menudo).

En ejecución no he encontrado ningún problema…

Saludos. Ramiro


([N1] Manuel,Cabrera) #6

Buenos días.

Yo no he encontrado ningún problema con la 7.18.

Ramiro, dale una vuelta, mis dibujos se imprimen exactamente igual que antes y te aseguro que se imprimen muchos al cabo del día.

En edición tampoco he notado nada y hace unas cuantas versiones que no tengo cierres.

Saludos.


([N4] Infortic) #7

A mi en los informes nativos me ha pasado lo que a ramiro.

Si pones proporcionar sin ampliar salen ridiculos.

He tenido que cambiarlo en todos a Estirar/Encoger.

Además de eso, la configuración de los márgenes no funciona, sólo funciona con “Por defecto”, como le pongas márgenes a mano o “Sin márgenes” se vuelve loco, imprime distintos márgenes en el mismo report dependiendo de si tienes seteada la impresora lógica o no, es decir, el mismo report con impresora lógica seteada sale bien, y si no está seteada sale desplazado a la derecha cortándote la parte derecha.

Lo peor es que estos problemas no se dan en la previsualización, es al imprimir cuando ocurren, por lo que ves en la vista previa no se corresponde con lo que se va a imprimir. WYSWYG al carajo…


([N4] juanjo) #8

Buenos días,

con la 7.18, en vDevelop he notado unos comportamientos extraños a la hora de arrastrar objetos. Otras cosas que me han extrañado bastante (no vi entera la presentación) es que ha desaparecido el botón de abortar transacciones en vAdmin y que ya no se pueden disparar procesos en segundo plano con los manejadores de objeto ¿?.

Saludos


([N3] pacosatu) #9

Hola.

En el siguiente hilo ya se comentaba el tema de la mala calidad de los dibujos en los informes nativos.

En la 7.18 por fin la impresión de los informes nativos se realiza con una resolución aceptable.
Yo había dejado de usar los informes nativos que contenían Logos precisamente por este tema.

Por supuesto, los dibujos deben estar siempre con la propiedad Proporcionar para que se adapten sin deformar a la caja que los contiene.

El botón de abortar transacciones lo han quitado porque generaba ciertos problemas.
Algunos hemos pedido que lo vuelvan a poner, espero que hagan caso.

Que no se puedan disparar procesos en segundo plano nunca se ha podido, lo que han hecho ha sido quitar la opción para evitar confusiones.

Es cierto que ha aumentado la inestabilidad de vDevelop. Un movimiento no previsto del ratón, un doble click a destiempo, y vDevelop se cierra inesperadamente o se queda con el relojito pasmao. La pérdida de los cambios no guardados es irremediable.

Ya he añadido como MEJORA de vDevelop un sistema de Autoguardado automático para recuperar los cambios no guardados ante cierres inesperados, algo habitual en herramientas de desarrollo, ¡¡que el tiempo es muy caro para perderlo tontamente!!

Saludos
Paco Satué


([N2] ramiro) #10

Hola Paco:

Mi impresión es que los dibujos NO deben estar siempre con la propiedad Proporcionar…

A mi me ha vuelto a funcionar bien cuando los he puesto en “Estirar/Encoger” (antes estaban, creo recordar, en Proporcionar) y en esa “solución” coincido con Infortic.

Saludos. Ramiro


([N2] ramiro) #11

Respecto a la cancelación de Transacciones…

No lo había advertido, pero un par de veces lo he usado en Cloud porque una transacción en que esperaba 1000 ó 2000 cambios iba por 100.000. Mejor aborto y lo reviso que asumir la modificación o pérdida de cientos de miles de datos porque equivoqué u olvidé la inclusión de un filtro.

Me parece increíble que desaparezca y no se haga público de forma relevante…
Espero que se restituya pronto.

Saludos. Ramiro


([N1] Manuel,Cabrera) #12

Hola.

Los dibujos los tengo con Proporcionar y salen bien.

En cuanto a los márgenes, los tengo fijos y salen como siempre.

Saludos.


([N4] juan.pescapuerta) #13

Buenas

Excepto por un pequeño problema con los casilleros, funcionando sin problemas con 150 usuario interactuando

Saludos


([N4] tutormcsoftware) #14

Por ahora no he notado nada que vaya mal, salvo lo comentado en el foro.
Pero el vDevelop se cierra (deja de funcionar) unas cuantas veces al día, y no tengo un patrón estudiado.
Pero he notado que se cuelga más cuando estoy trabajando con objetos vb o qml. Y casi siempre es al darle F5 para ejecutar. Curiosamente no se cuelga el vClient, sino el vDevelop y no siempre puesto que en la misma situación aparente, otras veces no se cuelga.
La verdad es que me sería muy difícil trazar un patrón. Así que me aguanto.


([N1] Juan) #15

http://velneo.es/foros/topic/precaucion-probar-nombre-tabla/

Tengo el error descrito, tener precaucion al replicar el error, porque baja el vServer, haber descartar que sea mi maquina aunque ya probe en 2 windows diferentes.


([N1] Juan) #16

CON ss palabra reservada del Sistema windows. No se puede usar


([N3] blanyi) #17

Gracias a todos los que han aportado su comentario respecto a como les ha ido con la nueva versión de Velneo.

Creo que fue buena haber planteado la inquietud porque sirvió para que algunos conocieramos algunos detalles que tal vez no conociamos.

YIMY MORA ACONCHA