Carga Lista


([N4] Ramon Denuc) #1

Hola Foro,

En una Carga lista [TABLA, INDICE, registro a buscar] me da 1 cuando se perfectamente que no hay ningun registro en la tabla.

¿Sabe alguien porque puede ser?

Saludos


([N1] aztecmexico) #2

“registro a buscar”, es donde van las partes de resolución del índice, si es un índice que consta de varias partes y no las indicas todas, solo la primera o segunda, puede que 1 o más registros cumplan con la condición.

Si te regresa una lista de mínimo 1 es que encontró como mínimo ese registro que cumple, revisa el índice como lo tienes definido y las partes que lo componen.

En cada cuadro de resolución marcado como opcional va el contenido que buscas, un cuadro para cada parte del índice en el mismo orden que los defines en el índice.

Saludos.


([N4] Ramon Denuc) #3

Hola Aztecmexico,

Todo lo que me explicas lo tengo muy claro como va, es por esa razón, que me extraña que de una tabla que se que esta vacía, al hacer una Carga Lista me devuelva a través de un sysListSize el valor 1, cuando debería ser 0.

Es hay donde tengo la duda, porque devuelve 1.

Saludos


([N2] Esfero) #4

As probado a regenerar los índices??, hace unos días me encontré con algo parecido, ma aparecía duplicado un registro y no había razón aparente para ello, la regeneración de los índices solucionó el problema.


([N4] Ramon Denuc) #5

Hola Esfero,

Fue una de las primeras cosas que hice, y nada, sigue dando 1

Tabla corrupta ?

Puede ser en Velneo ?

Saludos


([N4] Infortic) #6

Hola.

Recorre ese registro con un mensaje #ID para ver si hay algo guardado

¿Desde el vDataclient, abriendo la tabla sin ningún índice te muestra algo?


([N4] Ramon Denuc) #7

Hola,

Con el vDataClient no sale nada en ninguno de sus Indices, vacíos!!!

Con un Recorre + #ID no sale nada.

Saludos


([N4] Infortic) #8

Hola.

Decía abrirla SIN SELECCIONAR INDICE, para saber si tiene un registro sin indizar (aunque cargar lista siempre lo carga por índice).

No sé, nunca me ha pasado.

Pon una captura de la tabla y del código que provoca sysListSize=1 a ver si a alguien se le ocurre algo.

Si no… eliminar el fichero de la tabla para que la vuelva a generar.