Campo numerico decimales y signo separador de miles


([N1] mauricio.gonzalez.telefonica) #1

Hola a todos, tengo un campo establecido en sus propiedades en la tabla como:
Tipo:numerico
Longitud: 5
Decimales: 2
Signo: Verdadero
en Ejecución no consigo ver ni los decimales ni el signo separador de miles.


([N2] overall) #2

Hola, yo hace tiempo que lo estoy exponiendo, pero todavía nadie me ha sabido dar la solución (ni en formularios ni en rejillas)
Saludos
Overall


([N1] mauricio.gonzalez.telefonica) #3

Hola overall.massoicb, en rejillas tienes en las propiedades de columna la opcion [b]separador de miles cuerpo: Verdadero[/b] no lo he probado, pero deberia de funcionar...


([N1] mauricio.gonzalez.telefonica) #4

Hola, el [b]separador de miles cuerpo[/b] no funciona, he observado el los objetos [b]Constante[/b], y creo que por ahí van los tiros, aunque debo aprender a utilizarlos...


([N4] fgutierrez.velneo) #5

Como hemos comentado, la opción para formatear la salida de los números por el momento es el uso de la función numberToString (http://v7.velneo.es/foros/topic/mostrar-decimales-en-las-rejillas-de-los-campos-formula).
De todas formas es algo que tendremos en cuenta para próximas versiones, al igual que el separador de miles.
De todas formas, respondiendo a mjgm, los números presentan decimales si los tienen. ¿Se da el caso de que no se presenten?
Un saludo.


([N1] mauricio.gonzalez.telefonica) #6

Hola fgutierez, gracias por la respuesta, efectivamente, si tiene decimales y el digito es distinto de cero si los muestra:
ejemplo: 1.234,27 muestra: 1234,27
ejemplo: 1.234,20 muestra: 1234,2