Campo memo


([N1] lsmsusvilla) #1

Mas que un problema creo que es una putad... y un motivo para pensarse en seguir utilizando Velneo. Tengo una aplicacion con un campo objeto binario en el que tenia incrustados archivos pdf. Pues bien al actualizar a la version 7.7 ya no habre dichos archivos, exportandolos como antes a un directorio temporal y luego abriendolos. Ha cambiado algo en relacion con los campos binarios o es que sencillamente se han perdido todos los datos. Ha alguien mas le ha pasado


([N4] eic) #2

Hola.

Tengo, en una aplicación, exactamente lo mismo que tú: un campo objeto binario, con archivos pdf (y de otros tipos) almacenados. El usuario puede visualizarlos (del mismo modo: los descargo a una carpeta temporal, y los abro). Acabo de comprobarlo con la versión 7.7, y me funciona perfectamente.

Si posteas el proceso que usas, a lo mejor podemos ver qué ocurre.

Saludos,

Fran Varona


([N4] info) #3

Hola
No se si tendrá alguna relación, juraría que me han desaparecido al cambiar la versión, algunos objetos dibujo que tenia en algunos registros y estoy casi convencido al 99%, pero tendría que cargar otra vez la V7.6 para comprobarlo.
un saludo
Miguel


([N1] lsmsusvilla) #4

Si, el proceso es este que es exactamente el mismo que utilizaba antes de la actualizacion y funcionaba perfectamente, al hacer doble click en una rejilla, ahora no me deja ni tan siguiera exportar el archivo binario.

[attachment=17734,1463]


([N1] Pepeto) #5

Has comprobado que la carpeta "Temporal" que utilizas en la senda, ¿existe?
Puede que sea por problemas de permisos de acceso a la carpeta

un saludo
Jose Luis


([N1] lsmsusvilla) #6

Si Pepeto, mismo ordenador, mismo programa, justo antes de actualizar funcionaba perfectamente, actualizo al aversion 7.7 y ya no funciona. El problema es que ahora estoy pensando como retomar la version v7.6 para por lo menos poder exportar los campos binarios a un directorio pero al ahber guardado la aplicacion ya una vez en la version 7.7 creo que ya no me lo leera si reinstalo el vDevelop para crear un proceso de exportacion de archivo.


([N4] eic) #7

Hola.

Creo recordar que en la 7.7 se cambiaba el comportamiento de isEmpty().

Yo uso la siguiente instrucción:

Exportar binario CAMPO, "c:/temp/archivo.pdf", BOK

Quizá puedas quitar lo de tempPath() por si acaso tiene que ver con eso.

Saludos,

Fran Varona


([N1] lsmsusvilla) #8

Bueno resulta que tanto en el ordenador del trabajo como en el de casa el problema con la aplicacion persiste, antes de actualizar tenia una tabla con un campo objeto binario, al hacer doble click en una rejilla ejecutaba un evento que exportaba el archivo incrustado y luego lo abria. Al actualizar esta funcion ya no funciona, pero si le doy de alta un archivo adjunto nuevo si que lo exporta correctamente y te lo abre sin problemas.
Es como si al haber hecho la actualizacion se hubieran corrompido todos los campos binarios que habia con anterioridad, parece ilogico pero de momento es asi. A alguien mas le ha psado.


([N2] jpamiesb_1712) #9

Hola [N3] lsmsusvilla
Este posible fallo, lo has reportado a soporte
Saludos
Catarso

Un dia mas, un dia menos
Para cuando dice que lo quiere........jajajaja