Bug en el visor Html


([N1] Pepeto) #1

Estoy realizando pruebas con el objeto Visor Html incrustado en un formulario, y tras un buen rato intentando acceder a ciertas paginas web, me he desesperado viendo como no me funcionaba el objeto visor Html

Ya con mas calma y algo tan sencillo, he vuelto a probar, con la web de http://velneo.es y con mi propia web http://www.ascsl.com y tambien me ha funcionado

Y he vuelto a la carga con las pruebas iniciales que se me resistian y tras varias comprobaciones, he llegado a la conclusion de que las paginas https:// (webs seguras) muestran un error al cargar en el Visor Html del navegador

No he podido cargar varias paginas webs de bancos.

Si alguien lo puede confirmar, o ¿estoy haciendo algo mal?

un saludo

Jose

 


([N4] Jorge) #2

Confirmado, nos sucede lo mismo.

 

Este control de formulario está bastante limitado, por un lado el problema de https (espero que sea un bug), por otro el de no poder establecer la página de inicio en tiempo de desarrollo y por último el no poder leer la ruta de navegación en la que se encuentra el usuario.


([N4] velavisual) #3

@Pepeto

 

Lo haces todo correctamente, lo que pasa es que las webs seguras no funcionan en el navegador.

Creo que había una incidencia al respecto.

 

saludos

Antonio Vela

http://www.velavisual.com

 

 

 

 


([N1] filipeagg) #4

A min me parece que es un proprio problema de qt y del openwebquit, que usa velneo v7.

Por defecto las librerias qt no permiten navegar en direciones del tipo https, o permite pero modificando y añadindo modulos al openwebkit.

Esta visto que velneo aun no lo ha hecho.

Me he puesto a aprender c++ y qt, me esta dejando muy satisfecho.

 Por ejemplo el vWebClient es un modulo (plugin) que tiene qt para pasar una aplicacion a web.

 

 


([N2] gegeo) #5

@filipeagg

 

A min me parece que es un proprio problema de qt y del openwebquit, que usa velneo v7.

Por defecto las librerias qt no permiten navegar en direciones del tipo https, o permite pero modificando y añadindo modulos al openwebkit.

[...] Por ejemplo el vWebClient es un modulo (plugin) que tiene qt para pasar una aplicacion a web.

 

¿Quieres decir que vWebClient no funcionaría bajo protocolos https?

 

vSaludos

 

 


([N1] filipeagg) #6

No lo sé.

Pero en principio no tiene nada que ver.

El open webkit es un modulo libre en lo cual estan basados navegadores como el google crhome. Velneo v7 lo usa para las operaciones javascript y para los visores html en los formularios.

En el caso del vwebcliente, nada tiene que ver con el open webkit, pues el navegador del cliente no es el open webkit.


([N2] gegeo) #7

Entiendo que no tiene nada que ver con el openwebkit, pero como comentabas la posibilidad de que sean las propias librerias de QT las que no soportan el HTTPS, de ahi venia mi duda.

 

En cualquier caso, he remitido un ticket a soporte para confirmar esto, ya que me puede suponer ahora mismo un problema, o problemón.

 

vSaludos


([N2] gegeo) #8

Buenas,

 

Os transcribo la respuesta que me ha facilitado de momento soporte:

 

El control web incrustado en todo Velneo V7 soporta https si el cliente tiene instalado OpenSSL.
Puedes instalarlo para windows en http://www.slproweb.com/products/Win32OpenSSL.html.
En otros sistemas operativos viene instalado o se instala de otra manera.
En Linux y Mac suele estar instalado.

 

Estoy pendiente que me confirmen si en el futuro dejase de ser un Bug (a fecha de hoy registrado con el numero 1263), y no haga falta la instalacion de OpenSSL.

 

vSaludos


([N1] Pepeto) #9

@Gegeo

 

Gracias por la informacion

un saludo

Jose Luis


([N1] info) #10

Este bug informe yo a velneo creo recordar que con la salida de la v7 , la primera, y esta sin resolucion a fecha de hoy.


([N2] gegeo) #11

Para vuestra información, esta es la ultima info que tengo de soporte.

 

Las librerias OpenSSL no se incluyen en la herramienta por motivos legales, lo cual os transcribo a continuación:

 

"Debido a las restricciones de importación/exportación en algunos países no podemos suministrar el OpenSSL Toolkit en nuestras instalaciones. Los desarrolladores que quieran usar comunicación SSL en sus desarrollos deberán asegurarse de que sus usuarios tengan instaladas las librerías apropiadas, o deberían consultar a un profesional legal para asegurarse que la aplicación que utiliza código del proyecto Open SSL están correctamente certificadas para importar y exportar en relevantes regiones del mundo."

 

Parece ser que el proximo paso a seguir por Velneo, sera publicar un articulo al respecto con link a la descarga de dicha libreria, asi que entiendo, unicamente sera posible ver URL seguras, siempre y cuando el cliente instale dichas librerias.

 

vSaludos