bug en combobox


([N1] servinfordelfin) #1

Hola me parece que hay un error en el combobox, si coges los datos de una tabla estática va bien pero si lo coges de una tabla da error y se cierra la aplicación. Gracias


([N1] JorgeVelasco) #2

Buenas.

Tanto los combobox como los listbox sólo son para utilizarse con tablas estáticas.

Un saludo.

 


Jorge Velasco

SISTEMA BINARIO


([N1] servinfordelfin) #3

Hola Jorge gracias por tus respuestas (!!y más en domingo!!) estoy ya probando lo que me has contestado en los anteriores temas.

Respecto a lo que he escrito antes me he dado cuenta que no hay ningún error en el combobox, el error soy yo. Si que funciona y además puede ser interesante utilizarlo pues supongamos una tabla con el estado de las facturas, los clientes pueden predefinir los estados a su antojo y es más cómodo y rápido usar un combobox que un buscador.

Lo que me ha pasado y lo comento por si le sirve a alguien del foro es que he traído un informe de otro vserver (copiar y pegar) lo he incrustado en un formulario y ahí es donde he añadido el combo, cada vez que entraba se me cerraba la aplicación y daba error. Pensaba que era por el combo pero tras estar varias horas intentando ver qué pasaba a resultado ser que en el informe tenía una pequeña imagen en el encabezamiento, claro el origen ya se había perdido pues era de otro vserver. Aunque había traído también la imagen en el informe aparecia mal la ruta (imagen encabezado@...) había puntos en vez del nombre de la solución y en vez de salir la imagen en blanco se cerraba la aplicación lo he cambiado por la imagen que tengo en mi vserver y ya está

Con esto se me acaba de ocurrir otra pegunta, ¿hay alguna forma de copiar una solución de un vserver a otro?

Gracias otra vez Jorge y bona nit.