Actualización de 7.140 a 7.15.0


([N1] vlinares) #1

Buenas tardes a todos…
Quiero actualizar de 7.14.0 a 7.15.0
¿Se puede reinstalar la versión nueva sobre la antigua o debo desinstalar la versión versión anterior?

Un saludo
Vicente


([N4] ofsantana) #2

Hola, debes desinstalar todos los complementos de la versión 7.14 y luego sí podrás instalar la nueva versión. Puedes estar tranquilo que no vas a perder ningún dato. Es totalmente transparente, salvo las anotaciones del blog en cuánto a cosas a tener en cuenta. Para el caso de la 7.15, debes asignar permisos de crear instalación y de Exportar en el vAdmin.

Saludos.


([N1] intelpric) #3

Saludos cordiales…

Problema en la v7 7.15

En las evaluaciones he realizado de la ultima versión de velneo he encontrado una falla en el uso de librería externa los procesos se cuelgan y cierran inesperadamente la aplicaciones.

En la versión anterior( 7.14 ) no existía este problema, ha de ser algún cambio en la estructura del lenguaje o bien en la localización de la llamada de las librería.

Mucho cuidado con la actualización, si dependes de librerías externas…

vGestor
Gestor de desarrollo en velneo v7
www.vgestoradmin.blogspot.com


([N4] velavisual) #4

@interpric

¿Podrías darnos más información sobre los cuelgues de las aplicaciones que usan librerías externas?

¿Con qué soluciones te dá problemas?

¿Lo has notificado a soporte?

Agradecer tu comentario porque es algo que nos afecta a todos.


([N1] intelpric) #5

Saludos cordiales…

Me explico mejor :

Tengo una librería creada en C que funciona correctamente en velneo v7 7.14 , pero en la 7.15 no . En cada actualización que presenta velneo yo evaluó en la nube las causas y las consecuencias que pueden surgir en cada actualización. En este caso resultó que la librería cierra el proceso como si esta no fuera compatible con la nueva versión de velneo.

La librería la utilizo para extraer un ID del hardware del computador.

La pregunta seria:
¿ Por que funciona en la V7 7.14 y no en la v7 7.15 ?

No he podido reportarlo a soporte…

vGestor
Gestor de desarrollo en velneo v7
http://www.vgestoradmin.blogspot.com


([N1] vlinares) #6

Buenos días…
Quería empezar a utilizar las librerías de vMail y voy a actualizar a 7.15.
¿Alguien sabe si presentan estas librerías algún problema con la nueva versión?

Gracias de nuevo.

Vicente


([N4] rpaton) #7

Hola Pablo:
Para solucionar el problema cuando declaras la DLL en el campo “Nombre” NO pongas la EXTENSION como se indica en las instruciones:

http://velneo.es/info_v7_714_es/velneo_vdevelop_v7/proyectos_objetos_y_editores/libreria_externa/

 Saludos.

 Ricardo Patón

([N1] intelpric) #8

Saludos…

Hay otra cosa que evita el funcionamiento de la librería ya he probado la opción que comentas y sigue sin funcionar.

vGestor
Gestor de desarrollo en velneo v7
http://www.vgestoradmin.blogspot.com